pobo博易大师期货指标(大集合)

首页 指标 博易大师 pobo博易大师期货指标(大集合)

目录:

  1. 利多方舟 2
  2. 变色MACD 2
  3. 仿DDX 4
  4. 博易版(king趋势) 4
  5. 无敌趋势 5
  6. 粉K线 5
  7. 无敌精灵 5
  8. 买卖航标 6
  9. 天风地火 6
  10. 无影手 7
  11. 合并即涨 8
  12. 顶底奇准 8
  13. 一品操盘 9
  14. ★底部提示:副 10
  15. 博易顶底王 11
  16. 趋势线(主图) 11
  17. 变色主图线 12
  18. CCI主图K线 12
  19. 优化MACD 12
  20. 博易指标公式(量能多空) 12
  21. 多空参考 13
  22. 趋势顶底 14
  23. 资金量指标 15
  24. 机构做空能量线 15
  25. 专业快刀手 15
  26. 副图K线 16
  27. 一品操盘 17
  28. 天机均线 17
  29. 无双多空 17
  30. 金山银山 18
  31. 量能指标 18
  32. 即时趋势 19
  33. 快慢多空 19
  34. 彩色K线 19
  35. 量能多空 19
  36. 鳄鱼分形 20
  37. 多空之王 22

 

 

 

博易大师变色均线代码(以21日均线-“万能线”为例)

一、当均线开始上翘时变彩色,当均线开始下拐后变绿色

MA21:MA(C,21),COLOR00FF00,LINETHICK4;

PARTLINE(MA21>REF(MA21,1),MA21),COLORRED,LINETHICK4;

PARTLINE(MA21<REF(MA21,1),MA21),COLOR008800,LINETHICK4;

二、当K线突破均线变彩色,当K线跌破均线后变绿色

MA21:MA(C,21),COLOR00FF00,LINETHICK4;

PARTLINE(C>MA21,MA21),COLORRED,LINETHICK4;

PARTLINE(C<MA21,MA21),COLOR00CD00,LINETHICK4;

 

利多方舟

VAR1:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));

VAR2:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));

VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));

DRAWTEXT(CROSS(VAR2,MA(VAR3,6)),(CLOSE*0.95),'↑'),COLOR0000FF;

DRAWTEXT(CROSS(MA(VAR3,6),VAR1),(HIGH * 1.035),'卖'),COLORFFFF34;

年:MA(CLOSE,30),COLORGREEN;

STICKLINE(C>=年 AND C>=O,C,O,3,0),COLORRED;

STICKLINE(C>=年 AND C>=O,H,L,0,0),COLORRED;

STICKLINE(C>=年 AND C<O,C,O,3,1),COLORRED;

STICKLINE(C>=年 AND C<O,O,H,0,0),COLORRED;

STICKLINE(C>=年 AND C<O,C,L,0,0),COLORRED;

STICKLINE(C<年 AND C>O,C,O,3,1),COLORFFFF00;

STICKLINE(C<年 AND C<=O,C,O,3,1),COLORFFFF00;

STICKLINE(C<年 AND C<=O,H,L,0,1),COLORFFFF00;

STICKLINE(C<年 AND C>O,C,H,0,1),COLORFFFF00;

STICKLINE(C<年 AND C>O,O,L,0,1),COLORFFFF00;

符号↑为"买”

 

变色MACD

DIFF:(EMA(CLOSE,12) - EMA(CLOSE,26))*20,COLORFFFFFF,LINETHICK1;

DEA:EMA(DIFF,9),COLOR00FFFF,LINETHICK1;

MACD:2*(DIFF-DEA), COLORSTICK;

MACD1:2*(DIFF-DEA),COLORRED,LINETHICK0;

MACD2:SMA(MACD1,0,3),COLORFFFF00,LINETHICK0;

STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,2,0),COLORRED;

STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,2,0),COLOR00FFFF;

STICKLINE(MACD1<MACD2,0,MACD1,1,0),COLOR40FF00;

S1:=MACD<0;

S2:= (MACD>=0);

S3:=BARSLAST(CROSS(DIFF,DEA));

S4:=REF(S3,S3+1);

S5:=DEA>REF(DEA,S4);

S6:=DEA;

上成立:=CROSS(DIFF,DEA) AND S5;

下成立:=CROSS(DIFF,DEA) AND S6;

L1:=(EMA(CLOSE,3) - EMA(CLOSE,13));

L2:=EMA(L1,9);

L3:=BARSLAST(CROSS(L1,L2));

L4:=REF(L3,L3+1);

L5:=L2;

变盘:CROSS(L1,L2) AND L5,LINETHICK0,COLORD6FF9C;

STICKLINE(变盘,5,-5,4,1),COLORD6FF9C;

成立距今:BARSLAST(CROSS(DIFF,DEA)),LINETHICK0;

L6:=BARSCOUNT(CLOSE);

DRAWTEXT(CROSS(L1,L2),DIFF,'买'),COLOR0000FF;

DRAWTEXT(CROSS(L2,L1),DIFF,'卖'),COLORFFFF00;

REF(DEA,S3),POINTDOT,COLORGREEN;

IF(L1>L2,REF(DEA,S3),0),POINTDOT,LINETHICK5,COLORB078FF;

IF(MACD<0,REF(DEA,S3),0),POINTDOT,LINETHICK5,COLORGREEN;

LS:=IF(DIFF>DEA AND DIFF>0,1,0);

加速上扬:IF(REF(LS=0,1) AND LS=1,0.1,0);

XG1:CROSS(MACD1,MACD2) AND MACD1<0,LINETHICK0;

XG2:CROSS(DIFF,DEA),LINETHICK0;

M1:=MACD>REF(MACD,1) AND DIFF<DEA;

绿柱短了:M1 AND COUNT(M1,10)=1 AND C>MA(C,55) AND COUNT(MACD<0,5)>=5,LINETHICK0;

DRAWTEXT(绿柱短了,MACD,'绿柱短了'),COLOR00FF80;

 

渔家乐

 

渔家:3*SMA((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100,5,1),3,1),LINETHICK2 , COLORYELLOW;

渔家乐: IF(CROSS(渔家,MA(渔家,10)) AND 渔家<=10,35,0),LINETHICK3 , COLORMAGENTA;

渔家出海: IF(CROSS(渔家,MA(渔家,10)) AND 渔家<35,70,0),LINETHICK3 ,  COLORRED;

渔家网: IF(CROSS(MA(渔家,9),渔家) AND 渔家>70,110,72),LINETHICK1 ,  COLORCYAN;

DRAWICON(CROSS(渔家,62),68,1);

DRAWICON(CROSS(渔家,72),70,1);

DRAWICON(CROSS(渔家,66),72,1);

DRAWICON(CROSS(渔家,68),66,1);

DRAWICON(CROSS(76,渔家),70,2);

DRAWICON(CROSS(68,渔家),84,2);

DRAWICON(CROSS(66,渔家),80,2);

DRAWICON(CROSS(64,渔家),70,2);

准备下网: IF(渔家<=10,30,0),STICK,COLOR8080FF,LINETHICK4;

此处下网: IF(CROSS(渔家,10),45,0),STICK,COLORRED,LINETHICK4;

DRAWTEXT(此处下网,40,'关注!!!'),COLORYELLOW;

准备休渔吧: IF(渔家>=90,70,0),STICK, COLORGREEN;

休渔吧: IF(CROSS(84,渔家),100,0),STICK,COLOR77AAFF,LINETHICK5;

DRAWTEXT(休渔吧,98,'回家!'),COLOR77AAFF ;

水面: 72, COLORCYAN ;

网架: 105;

水底: 10;

渔家2: MA(渔家,9),LINETHICK2 ,COLORFF0000;

IF(CROSS(渔家,MA(渔家,6)) AND 渔家2<45,渔家2,0),COLORCCB3E2 ,LINETHICK3 ;

 

仿DDX

 

VOL,VOLSTICK;

VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));

成交:VOL,VOLSTICK;

主买:IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),COLORRED,COLORSTICK;

主卖:IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-VAR1*(HIGH-LOW),0-VOL/2)),COLOR00FF00,COLORSTICK;

增仓减仓: IF(主买>=(ABS(主卖)),主买+主卖,主卖+主买),COLORYELLOW,LINETHICK2;

 

博易版(king趋势)

 

QS0:=((CLOSE - LLV(LOW,120)) / (HHV(HIGH,120) - LLV(LOW,120)));

QS1:=((QS0 / 1) * EMA(CLOSE,20));

QS:=SMA(QS1,3,1);

QD0:=((CLOSE - LLV(LOW,119)) / (HHV(HIGH,119) - LLV(LOW,119)));

QD1:=((QD0 / 1) * EMA(CLOSE,20));

QD:=SMA(QD1,5,1);

QF0:=((CLOSE - LLV(LOW,118)) / (HHV(HIGH,118) - LLV(LOW,118)));

QF1:=((QF0 / 1) * EMA(CLOSE,20));

QF:=SMA(QF1,5,1);

PX1:=((((QS + QD) + QF) / 3) + EMA(CLOSE,20));

PX2:=MA(PX1,2);

PX3:=MA(PX1,3);

YY:=((((2 * CLOSE) + HIGH) + LOW) / 4);

MA1:=MA(YY,45);

C1:=(PX1 - MA1);

M:=(PX2 - MA1);

O1:=(PX3 - MA1);

MA2:=MA(C1,8);

BO:=0.5,COLORRED;

STICKLINE((C1 >= M),M,(O1 - 0.03),4,0),COLORRED;

STICKLINE((C1 <= M),M,(O1+ 0.03),4,0),COLORFFFF00;

LIFE:=MA(C1,13),COLORGREEN;

A:MA(LLV(C1,120),3),COLORRED;

B:MA(HHV(C1,120),3),COLORGREEN;

 

 

 

无敌趋势

RSV1:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;

RSV2:=(CLOSE-LLV(LOW,35))/(HHV(HIGH,35)-LLV(LOW,35))*100;

J1:=SMA(RSV1,3,1);J2:=SMA(J1,3,1);

趋势线:3*SMA(RSV2,5,1)-2*SMA(SMA(RSV2,5,1),3,1),LINETHICK2,COLORFF84FF;

K:SMA(RSV2,3,1),LINETHICK2,COLORWHITE;

D:SMA(K,3,1),LINETHICK2,COLORF408F4;

DI:IF(趋势线<=10,30,0),LINETHICK2,COLORYELLOW;

KI:IF(CROSS(J2,J1) AND J2>85,70,100),LINETHICK2,COLOR00FF00;

强弱界线:49,POINTDOT,LINETHICK3,COLOR99AACC;

STICKLINE(趋势线>88,100,趋势线,4,1),COLORGREEN;

STICKLINE(趋势线<=10,0,趋势线,4,1),COLORYELLOW;

STICKLINE(COUNT(趋势线<REF(趋势线,1) AND 趋势线<10,2)=2,0,20,4,0),COLORRED;

STICKLINE(CROSS(J2,J1) AND J2>85,100,80,4,0),COLORGREEN;

DRAWICON(CROSS(趋势线,49),趋势线,1),COLORRED;

DRAWICON(FILTER(CROSS(D,K) AND D>88,10),D*1.05,2);

DRAWTEXT(CROSS(趋势线,49),47,'转强'),COLORRED;

DRAWTEXT(CROSS(49,趋势线),52,'转弱'),COLORGREEN;

 

粉K线

STICKLINE(CROSS(C,(HHV((H+L)/2,120))),O,C,12,1),COLOR33DDDD;

{历史新高:}STICKLINE(HHV(CLOSE,0)=CLOSE,O,C,10,0),COLORYELLOW;

STICKLINE(C>=O,CLOSE,OPEN,8,0),COLORRED;      STICKLINE(C>=O,CLOSE,OPEN,7,0),COLORRED;

STICKLINE(C>=O,CLOSE,OPEN,6,0),COLOR0000BB;   STICKLINE(C>=O,CLOSE,OPEN,5,0),COLOR0000CC;

STICKLINE(C>=O,CLOSE,OPEN,4,0),COLOR0000DD;   STICKLINE(C>=O,CLOSE,OPEN,3,0),COLOR0000EE;

STICKLINE(C>=O,CLOSE,OPEN,2,0),COLOR0000FF;   STICKLINE(C>=O,LOW,HIGH,1,0),COLORRED;

 

无敌精灵

空方:=(EMA(CLOSE,24)-EMA(CLOSE,4))/2*0.95;

0;多方:=(EMA(CLOSE,4)-EMA(CLOSE,24))/2*0.95;

多头:多方,COLORYELLOW;

空头:空方,,COLORFFFF00;

引路精灵:(多方-空方),COLORRED,LINETHICK2;

STICKLINE(多方>空方 ,0,多方 ,0.8 , 1),COLOREEAAFE;

STICKLINE(空方>多方 ,0,空方 ,0.8 , 1),COLORFFFF00;

STICKLINE(多方>空方 ,0 ,空方 ,0.8 , 1),COLOREEAAFE;

STICKLINE(空方>多方,0 ,多方 ,0.8 , 1),COLORFFFF00;

DRAWICON(CROSS(引路精灵 ,0 ) ,引路精灵+0.3,1 );

 

买卖航标

 

VAR1:=(CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100;

操盘线:SMA(VAR1,5,1),LINETHICK2,COLORRED;

趋势线:SMA(操盘线,3,1),LINETHICK2,COLORYELLOW;

买入航标:IF(CROSS(操盘线,趋势线) AND 趋势线<25,50,0),LINETHICK2,COLORRED;

DRAWTEXT(买入航标>0,50,'买入'),LINETHICK1,COLORRED;

卖出时间:IF(CROSS(趋势线,操盘线)AND操盘线>70,80,100),COLORGREEN;

DRAWTEXT(卖出时间<100,80,'卖出'),LINETHICK1,COLOR00FF00;

 

天风地火

 

{天风地火 N:1 100 3 M:1 100 30}

VAR0:=(3*CLOSE+LOW+OPEN+HIGH)/6;

多头线:(20*VAR0+19*REF(VAR0,1)+18*REF(VAR0,2)+17*REF(VAR0,3)+16*REF(VAR0,4)+15*REF(VAR0,5)+14*REF(VAR0,6)+13*REF(VAR0,7)+12*REF(VAR0,8)+11*REF(VAR0,9)+10*REF(VAR0,10)+9*REF(VAR0,11)+8*REF(VAR0,12)+7*REF(VAR0,13)+6*REF(VAR0,14)+5*REF(VAR0,15)+4*REF(VAR0,16)+3*REF(VAR0,17)+2*REF(VAR0,18)+REF(VAR0,20))/210,CIRCLEDOT,COLORRED,LINETHICK2;

空头线: MA(多头线,10), CIRCLEDOT,COLORGREEN,LINETHICK2;

STICKLINE(多头线>空头线,多头线,空头线,10,10),COLORRED;

STICKLINE(多头线<空头线,多头线,空头线,10,10), COLORGREEN;

STICKLINE(C>O,O,C,7,0),COLORRED;

STICKLINE(C>O,O,C,4,0),COLORB0B0FF;

STICKLINE(C>O,O,C,2,0),COLORYELLOW;

STICKLINE(C>O,L,H,0.1,0),COLORYELLOW;

STICKLINE(C< O,O,C,7,0),COLORFF2020;

STICKLINE(C< O,O,C,4,0),COLORFF6600;

STICKLINE(C< O,O,C,2,0),COLORFFCC66;

STICKLINE(C< O,L,H,0.1,0),COLORFFCC66;

STICKLINE(C=O ANDC>=REF(C,1),O,C,7,0),COLORRED;

STICKLINE(C=O ANDC>=REF(C,1),O,C,4,0),COLORB0B0FF;

STICKLINE(C=O ANDC>=REF(C,1),O,C,2,0),COLORYELLOW;

STICKLINE(C=O ANDC>=REF(C,1),L,H,0.1,0),COLORYELLOW;

STICKLINE(C=O AND C<REF(C,1),O,C,7,0),COLORFF2020;

STICKLINE(C=O AND C<REF(C,1),O,C,4,0),COLORFF6600;

STICKLINE(C=O AND C<REF(C,1),O,C,2,0),COLORFFCC66;

STICKLINE(C=O AND C<REF(C,1),L,H,0.1,0),COLORFFCC66;

VAR1:=(CLOSE*1.1)-(CLOSE*0.9)*80

 

无影手

A1:EMA((EMA(CLOSE,1)+EMA(CLOSE,3)+EMA(CLOSE,5))/3,3),COLORRED;

A2:EMA((EMA(CLOSE,3)+EMA(CLOSE,5)+EMA(CLOSE,7))/3,3),COLORRED;

A3:EMA((EMA(CLOSE,5)+EMA(CLOSE,7)+EMA(CLOSE,9))/3,3),COLORRED;

A4:EMA((EMA(CLOSE,7)+EMA(CLOSE,9)+EMA(CLOSE,11))/3,3),COLORRED;

A5:EMA((EMA(CLOSE,9)+EMA(CLOSE,11)+EMA(CLOSE,13))/3,3),COLORRED;

A6:EMA((EMA(CLOSE,11)+EMA(CLOSE,13)+EMA(CLOSE,15))/3,3),COLORRED;

A7:EMA((EMA(CLOSE,13)+EMA(CLOSE,15)+EMA(CLOSE,17))/3,3),COLORRED;

A8:EMA((EMA(CLOSE,15)+EMA(CLOSE,17)+EMA(CLOSE,19))/3,3),COLORRED;

A9:EMA((EMA(CLOSE,17)+EMA(CLOSE,19)+EMA(CLOSE,21))/3,3),COLORYELLOW;

A10:EMA((EMA(CLOSE,19)+EMA(CLOSE,21)+EMA(CLOSE,23))/3,3),COLORYELLOW;

A11:EMA((EMA(CLOSE,21)+EMA(CLOSE,23)+EMA(CLOSE,25))/3,3),COLORYELLOW;

A:=EMA((EMA(CLOSE,29)+EMA(CLOSE,31)+EMA(CLOSE,33))/3,3),COLORYELLOW;

B:=REF(A,1);

DRAWTEXT(A>B,(A+B)/2,'★'), COLORFF00FF;

DRAWTEXT(A<=B,(A+B)/2,'☆'), COLORGREEN;

{STICKLINE(A>B,A,B,8,0),COLORFF00FF;

STICKLINE(A<=B,A,B,8,1),COLORFF0000;}

A15:A-(A1-A*0.997),COLORFF1010;

A16:A-(A2-A),COLORFF2010;

A17:A-(A3-A),COLORFF3010;

A18:A-(A4-A),COLORFF4010;

A19:A-(A5-A),COLORFF5010;

A20:A-(A6-A),COLORFF6010;

A21:A-(A7-A),COLORFF7010;

A22:A-(A8-A),COLORFF8010;

A23:A-(A9-A),COLORFF9010;

A24:A-(A10-A),COLORFFC010;

A25:A-(A11-A*0.997),COLORFFE010;

STICKLINE(OPEN>=CLOSE ,O,C,9,0 ),COLORAAAAAA;

STICKLINE(OPEN>=CLOSE ,O,C,6,0 ),COLORBBBBBB;

STICKLINE(OPEN>=CLOSE ,O,C,2.4,0),COLORCCCCCC;

STICKLINE(OPEN>=CLOSE ,O,C,1.1,0),COLORDDDDDD;

STICKLINE(CLOSE>OPEN,O,C,9,0 ),COLOR6666CC;

STICKLINE(CLOSE>OPEN,O,C,6 ,0 ),COLOR7777DD;

STICKLINE(CLOSE>OPEN,O,C,2.4 ,0 ),COLOR8888EE;

STICKLINE(CLOSE>OPEN,O,C,1.1 ,0 ),COLOR9999FF;

STICKLINE(CLOSE>OPEN,OPEN,LOW,0.5,0),COLOR1199FF;

STICKLINE(CLOSE>OPEN,CLOSE,HIGH,0.5 ,0),COLOR1199FF;

STICKLINE(OPEN>=CLOSE,CLOSE,LOW,0.5 ,0),COLORCCCCCC;

STICKLINE(OPEN>=CLOSE,OPEN,HIGH,0.5 ,0),COLORCCCCCC;

VAR31:=(ZIG(3, 19)>REF(ZIG(3,19),1) ANDREF(ZIG(3,19), 1)<REF(ZIG(3,19), 2));

STICKLINE(VAR31=2,L*0.95,L*0.98,8,0),COLOR0000FF;

DRAWTEXT(VAR31=2,L*0.95,'3天'),COLORYELLOW;

STICKLINE(VAR31=4,H*1.05,H*1.02,8,0),COLOR9966FF;

DRAWTEXT(VAR31=4,H*1.06,'5天'),COLORYELLOW;

STICKLINE(VAR31=7,L*0.95,L*0.98,8,0),COLOR00FFFF;

DRAWTEXT(VAR31=7,L*0.95,'8天'),COLORYELLOW;

STICKLINE(VAR31=12,H*1.05,H*1.02,8,0),COLORFF33FF;

DRAWTEXT(VAR31=12,H*1.06,'13天'),COLORYELLOW;

STICKLINE(VAR31=20,L*0.95,L*0.98,8,0),COLOR0066FF;

DRAWTEXT(VAR31=20,L*0.95,'21天'),COLORYELLOW;

STICKLINE(VAR31=33,H*1.05,H*1.02,8,0),COLORFFFF00;

DRAWTEXT(VAR31=33,H*1.06,'34天'),COLORYELLOW;

STICKLINE(VAR31=54,L*0.95,L*0.98,8,0),COLOR006600;

DRAWTEXT(VAR31=54,L*0.95,'55天'),COLORYELLOW;

STICKLINE(VAR31=88,H*1.05,H*1.02,8,0),COLOR00FF00;

DRAWTEXT(VAR31=88,H*1.06,'89天'),COLORYELLOW;

STICKLINE(VAR31=143,L*0.95,L*0.98,8,0),COLORCCFFFF;

DRAWTEXT(VAR31=143,L*0.95,'144天'),COLORYELLOW;

STICKLINE(VAR31=232 ,H*1.05,H*1.02,8,0),COLORFF0033;

DRAWTEXT(VAR31=232,H*1.06,'233天'),COLORYELLOW;

STICKLINE(VAR31=376,L*0.95,L*0.98,8,0),COLORFF9966;

DRAWTEXT(VAR31=376,L*0.95,'377天'),COLORYELLOW;

 

合并即涨

Var0:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;

Var3:=SMA(Var0,3,1);

Var1:=SMA(Var3,4,1)-10;

Var4:=(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))*100;

Var5:=SMA(Var4,3,1);

Var2:=SMA(Var5,4,1)-90;

STICKLINE(REF(Var1,1)<Var1,Var1,REF(Var1,1),10,0),COLOR0000FF;

0, CIRCLEDOT;

STICKLINE(REF(Var1,1)>Var1,Var1,REF(Var1,1),5,0),COLOR00ff00;

STICKLINE(REF(Var2,1)>Var2,Var2,REF(Var2,1),10,0),COLOR0000FF;

STICKLINE(REF(Var2,1)<Var2,Var2,REF(Var2,1),5,0),COLOR00ff00;

0,COLOR0000FF;

 

顶底奇准

买:=MA(CLOSE,1);

卖:=(LOW+HIGH+CLOSE)/3;

奇:= MA(卖,5);

准:= HHV(奇,10);

急卖奇准:IF(HHV((买<准),5),50,10),COLORFF6699;

STICKLINE(急卖奇准=10,50,10,1,1),COLORFF6699;

短卖奇准:IF(HHV((买<准),10),50,20),COLORGREEN;

STICKLINE(短卖奇准=20,50,20,1,0),COLORGREEN;

TR:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW -

REF(CLOSE,1)))),5);

HD:=(HIGH - REF(HIGH,1));

LD:=(REF(LOW,1) - LOW);

DMP:=(SUM(IF(((HD > 0) AND (HD > LD)),HD,0),5) );

DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),5);

神偷线:=(((DMP ) * 100) / TR);

辅助线:=((DMM * 100) / TR);

XXX:=(MA(((ABS((辅助线 - 神偷线)) / (辅助线 + 神偷线)) * 100),3));

奇准:= MA(卖,5);

买卖:=LLV(奇准,10);

底部关注:IF(((XXX > 88) AND (神偷线 < 5.8)),95,50),LINETHICK1,COLORYELLOW;

STICKLINE(底部关注=95,50,95,1.5,0),COLORYELLOW,LINETHICK1;

急买奇准:IF(LLV((买<买卖),5),75,50),COLORRED,LINETHICK1;

STICKLINE(急买奇准=75,50,75,1.5,0),COLORRED,LINETHICK1;

短买奇准:IF(LLV((买<买卖),10),85,50),COLORred,LINETHICK1;

STICKLINE(短买奇准=85,50,85,1.5,0),COLORred,LINETHICK1;

ADXR:=((XXX + REF(XXX,3)) / 2);

VAR1:=MA(LOW,1);

VAR2:=MA(HIGH,2);

VAR3:=MA(CLOSE,2);

VAR7:=REF(VAR3,1);

动向趋势线:XXX,LINETHICK2,COLORFFAA66;

 

一品操盘

{N:1,8,1;}

WR:=ABS(100-100*(HHV(HIGH,5)-CLOSE)/(HHV(HIGH,5)-LLV(LOW,5)));

IF(WR>0,WR,0),COLORYELLOW;

涨:CROSS(WR,50),POINTDOT,COLOR0000FF;

强:CROSS(WR,80),POINTDOT,COLORYELLOW;

回:CROSS(80,WR) AND WR>50,POINTDOT,COLORWHITE;

险:=COUNT(WR>60,7)>=5 AND WR>90;

跑:=COUNT(WR>60,7)>=5 AND CROSS(80,WR);

慌:WR<=10 AND WR>0,POINTDOT,COLOR00FF00;

绝:WR=0,POINTDOT,COLORFF6600;

买:REF(WR,1)<10 AND C>REF(C,1) AND C>O,POINTDOT,COLORWHITE;

攻:WR>=90 AND WR<100 OR (H=HHV(H,5) AND H/REF(C,1)>=1.05),POINTDOT,COLORFF00FF;

停:WR=100,POINTDOT,COLORRED;

优选:IF((涨 AND COUNT(WR<=10,6) AND REF(WR,1)>10)*100,100,50),COLORFF6666,LINETHICK2;

FLSZ:=V*N>REF(V,1) AND C>REF(C,1) AND C>O;

助涨:(涨 OR 强) AND FLSZ,POINTDOT,COLORFF00FF;

DRAWICON(优选=100,50,1);

{以下设置副图显示方式}

STICKLINE(WR>=50,50,WR,1,0),COLORWHITE;

STICKLINE(WR>=90 AND WR<100,100,95,4,0),COLORWHITE;

STICKLINE(WR=100,100,95,4,0),COLORFF00FF;

STICKLINE(WR<=10 AND WR>0,0,5,4,0),COLORWHITE;

STICKLINE(WR=0,0,5,4,0),COLORFF6600;

DRAWTEXT(涨,60,'涨'),COLOR0000FF;

DRAWTEXT(助涨,25,'▲'),COLORFF00FF;

DRAWTEXT(助涨,20,'‖'),COLORFF00FF;

DRAWTEXT(强,70,'强'),COLORYELLOW;

DRAWTEXT(回,50,'回'),COLORWHITE;

DRAWTEXT(险,100,'●'),COLOR0000FF;

DRAWTEXT(跑,100,'跑'),COLORFFFF00;

DRAWTEXT(慌,20,'慌'),COLOR00FF00;

DRAWTEXT(绝,20,'绝'),COLORWHITE;

DRAWTEXT(买,50,'买'),COLORWHITE;

DRAWTEXT(攻,50,'攻'),COLORFF00FF;

DRAWTEXT(停,85,'停'),COLOR0000FF;

50,COLORFFFF00,LINETHICK2;

10,COLOR00FF00;

90,COLOR00FF00;

 

★底部提示:副

Var2:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;

Var3:=SMA(SMA(Var2,3,1),3,1)/28.57;

Var4:=EMA(Var3,5);

Var5:=3*Var3-2*Var4;

AA:=CROSS(Var5,Var3) AND Var3<2.1 and c>o;

Var6:=(2*CLOSE+HIGH+LOW)/4;

Var7:=LLV(LOW,13);

Var8:=HHV(HIGH,13);

Var9:=EMA((Var6-Var7)/(Var8-Var7)*100,13);

VarA:=EMA(0.667*REF(Var9,1)+0.333*Var9,2);

多:Var9,COLORRED,POINTDOT;

空:EMA(0.382*REF(Var9,2)+0.618*Var9,12),COLORgreen;

STICKLINE(Var9>VarA,Var9,VarA,6,0),COLORred;

STICKLINE(Var9<=VarA,Var9,VarA,6,0),COLORFFCC66;

STICKLINE(AA,0,30,40,1),coloryellow;

STICKLINE(AA,16,29,38,0),colorred;

STICKLINE(AA,1,14,38,0),colorred;

STICKLINE(AA,15,15,40,1),coloryellow;

STICKLINE(AA,30,50,10,0),coloryellow;

STICKLINE(AA,53,55,10,1),colorred;

STICKLINE(AA,57,59,10,1),colorred;

STICKLINE(AA,61,63,10,1),colorred;

STICKLINE(AA,65,67,10,1),colorred;

STICKLINE(AA,69,75,12,0),colorffcccc;

DRAWTEXT(AA,85,'底'),coloryellow;

 

博易顶底王

VAR1:=LLV(LOW,34);

VAR2:=HHV(HIGH,30);

VAR3:=REF(CLOSE,1);

VAR4:=EMA((CLOSE-VAR1)/(VAR2-VAR1),3)*100;

主力:=SMA(MAX(CLOSE-VAR3,0),7,1)/SMA(ABS(CLOSE-VAR3),7,1)*100,COLORRED;

CC:主力,COLORWHITE;

散户:=VAR4;

VAR5:=(VAR4-LLV(VAR4,21))/(HHV(VAR4,21)-LLV(VAR4,21))*100;

Q1:IF(CROSS(VAR5,90) AND 散户<40,18,10);

Q2:IF(CROSS(主力,12) AND REF(散户,5)<20 AND REF(散户,3)<20,18,10);

P1:IF(CROSS(84,主力),82,90),COLOR99FF33;

P2:IF(CROSS(84,散户),82,90),COLORCYAN;

VY:=SMA((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100,5,1);

L2:=SMA(0.618*REF(VY,1)+0.382*VY,3,1), COLORFF9900;

L3:=MA(L2,5);

STICKLINE(L2>L3,L3+2,L3-2,5,0),COLORRED;

STICKLINE(L2<=L3,L3+2,L3-2,5,0),COLORGREEN;

80,POINTDOT;

50,POINTDOT;

20,POINTDOT;

 

趋势线(主图)

AA10:=MA(C,10);

BB10:=ATAN((AA10-REF(AA10,1)))*180/3.1416;

STICKLINE(BB10>1 AND AA10>REF(AA10,1), AA10,REF(AA10,1),8,0),COLORRED;

STICKLINE(BB10<1 AND AA10<REF(AA10,1), AA10,REF(AA10,1),8,1),COLORGREEN;

AA20:=MA(C,20);

BB20:=ATAN((AA20-REF(AA20,1)))*180/3.1416;

STICKLINE(BB20>1,AA20,REF(AA20,1),8,0),COLORYELLOW;

STICKLINE(BB20<1,AA20,REF(AA20,1),8,1),COLORBBCCCC;

 

变色主图线

O1:=MA(C,O), LINETHICK1;

N1:=MA(C,21), LINETHICK1;

M2:MA(C,55),COLOR0080FF;

PARTLINE(N1>M2,M2),COLORRED,LINETHICK2;

PARTLINE(N1<=M2,M2),COLORGREEN,LINETHICK2;

 

CCI主图K线

TYP:=(HIGH+LOW+CLOSE)/3;

CCI:=(TYP-MA(TYP,13))/(0.015*AVEDEV(TYP,13));

STICKLINE(CCI>=0,O,C,4,1),COLORRED;

STICKLINE(CCI>=0,O,L,0.1,0),COLORRED;

STICKLINE(CCI>=0,C,H,0.1,0),COLORRED;

STICKLINE(CCI<0,O,C,4,0),COLORCYAN;

STICKLINE(CCI<0,O,H,0.1,0),COLORCYAN;

STICKLINE(CCI<0,C,L,0.1,0),COLORCYAN;

DRAWTEXT(CROSS(CCI,-200) AND CCI>REF(CCI,1),L,'平空'),COLORGREEN;

DRAWTEXT(CROSS(200,CCI) AND CCI<REF(CCI,1),H,'平多'),COLORYELLOW;

DRAWTEXT(CROSS(CCI,100) AND CCI>REF(CCI,1),L,'加多'),COLORYELLOW;

DRAWTEXT(CROSS(-100,CCI) AND CCI<REF(CCI,1),H,'加空'),COLORGREEN

 

优化MACD

VAR1:=REF(CLOSE,1);

VAR2:=SUM(VOL,2)/((HHV(HIGH,2)-LLV(LOW,2))*100);

VAR3:=(CLOSE-VAR1)*VAR2;

VAR4:=SUM(VAR3,0);

VAR5:=SMA(VAR4,5,1);

VAR6:=SMA(VAR4,8,1);

OSC: VAR5-VAR6;

OSCMA: MA(OSC,4);

OSC, COLORSTICK;

VD:=SUM(IF(OSC>0,OSC*1.003,OSC*1.003>0),34)/34;

VE:=SUM(IF(OSC<=0,OSC*0.97,OSC*0.97<0),34)/34;

DRAWTEXT(CROSS(OSCMA,VE),OSCMA,'买'),COLOR0000FF;

DRAWTEXT(CROSS(VD,OSCMA),OSCMA,'卖'),COLOR3FEF12;

 

 

 

 

 

DRAWTEXT(CLOSE>上分形 AND REF(CLOSE,1)<REF(上分形,1),L博易指标公式(量能多空)

DKX:=(EMA(C,18)),POINTDOT;

STICKLINE(((C >=DKX) AND (C >= O)),H,L,0,1),COLORRED;

STICKLINE(((C >=DKX) AND (C >= O)),O,C,2,1),COLORRED;

STICKLINE(((C >=DKX) AND (C <= O)),H,L,0,0),COLORRED;

STICKLINE(((C >=DKX) AND (C <= O)),O,C,2,0),COLORRED;

STICKLINE(((C <DKX) AND (C >= O)),H,L,0,1),COLORGREEN;

STICKLINE(((C < DKX) AND (C >= O)),O,C,2,1),COLORGREEN;

STICKLINE(((C < DKX) AND (C <= O)),H,L,0,0),COLORGREEN;

STICKLINE(((C < DKX) AND (C <= O)),O,C,2,0),COLORGREEN;

VAR1:=(HHV(HIGH,15)-LLV(LOW,15));

VAR2:=(HHV(HIGH,15)-CLOSE);

VAR3:=(CLOSE-LLV(LOW,15));

VAR4:=(((VAR2/VAR1)*100)-70);

VAR5:=(((CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60)))*100);

VAR6:=((((2*CLOSE)+HIGH)+LOW)/4);

VAR7:=SMA(((VAR3/VAR1)*100),3,1);

VAR8:=LLV(LOW,34);

VAR9:=(SMA(VAR7,3,1)-SMA(VAR4,9,1));

VAR10:=IF((VAR9>100),(VAR9-100),0);

VAR11:=HHV(HIGH,34);

VAR12:=EMA((((VAR6-VAR8)/(VAR11-VAR8))*100),15);

VAR13:=EMA(((0.667*REF(VAR12,1))+(0.333*VAR12)),2);

MA11:=EMA(VAR13,5);

DRAWTEXT(CROSS(VAR12-VAR13,0),L-1,'多');

DRAWTEXT(CROSS(0,VAR12-VAR13),H+1,'空');

 

多空参考

(副图)

VAR1:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*80;

VAR2:=SMA(VAR1,10,1);

慢速:=SMA(VAR2,5,1);

RSV:= ((HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100)-70;

RSV1:= (CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

FATK:=SMA(RSV1,3,1);

形态:=SMA(FATK,3,1);

VARA:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

VARB:=SMA(VARA,3,1);

VARC:=SMA(VARB,3,1);

加速: EMA(3*VARB-2*VARC,2),COLORYELLOW;

底:6,COLOR00BF00;

大底:-6,COLOR007300;

顶:90,COLORFFA500;

大顶:100,COLORWHITE;

VAR11:=LLV(LOW,5)=LLV(LOW,45) AND CLOSE>=OPEN*1.04;

VAR22:=CLOSE>(REF(HIGH,1)+REF(LOW,1))/2;

买入:=VAR11 AND VAR22,LINETHICK2,COLORRED;

VAR3:=REF(CLOSE,1);

VAR4:=SMA(MAX(CLOSE-VAR3,0),6,1)/SMA(ABS(CLOSE-VAR3),6,1)*100;

卖出:=CROSS(80,VAR4),LINETHICK2,COLORGREEN;

VAR5:=CROSS(加速,100);VAR6:=CROSS(加速,-6);

VAR7:=CROSS(80,加速);VAR8:=CROSS(加速,6);

DRAWTEXT(VAR5,85,'注意顶'),COLORBLUE;

DRAWTEXT(VAR6,0,'关注底'),COLORRED;

DRAWTEXT(VAR7,95,'空'),COLORGREEN;

DRAWTEXT(VAR8,5,'多'),COLORMAGENTA;

 

趋势顶底

S1:80,COLOR996699,PRECIS0;

B1:20,COLORGREEN,PRECIS0;

A:=MA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19),COLORRED;

B:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));

D:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4),LINETHICK2;

长期线:A+100,COLOR9900FF;

短期线:B+100,COLOR888888;

中期线:D+100,COLORYELLOW,LINETHICK2;

见顶:(REF(中期线,1)>85 AND REF(短期线,1)>85 AND REF(长期线,1)>65) AND CROSS(长期线,短期线),PRECIS0;

顶部区域:(中期线<REF(中期线,1) AND REF(中期线,1)>80) AND (REF(短期线,1)>95 OR REF(短期线,2)>95 ) AND 长期线>60 AND 短期线<83.5 AND 短期线<中期线 AND 短期线<长期线+4,PRECIS0;

顶部:=FILTER(顶部区域,4);

底部区域:(长期线<12 AND 中期线<8 AND (短期线<7.2 OR REF(短期线,1)<5) AND (中期线>REF(中期线,1) OR 短期线>REF(短期线,1))) OR (长期线<8 AND 中期线<7 AND 短期线<15 AND 短期线>REF(短期线,1)) OR (长期线<10 AND 中期线<7 AND 短期线<1),PRECIS0;

STICKLINE(顶部,98,103,20,1),COLORRED;

STICKLINE(底部区域,-4,0,22,0),COLORGREEN;

STICKLINE(底部区域,40,44,22,0),COLORGREEN;

低位金叉:长期线<15 AND REF(长期线,1)<15 AND 中期线<18 AND 短期线>REF(短期线,1) AND CROSS(短期线,长期线) AND 短期线>中期线 AND (REF(短期线,1)<5 OR REF(短期线,2)<5) AND (中期线>=长期线 OR REF(短期线,1)<1),PRECIS0;

PARTLINE(中期线>REF(中期线,1),中期线),COLORMAGENTA,LINETHICK2;

PARTLINE(长期线<=REF(长期线,1),长期线),COLORFFFF00,LINETHICK1;

STICKLINE(低位金叉,0,4,11,0 ),COLORRED;

S0:10,COLORCC6633,LINETHICK2,PRECIS0;

B0:90,COLOR9966BB,LINETHICK2,PRECIS0;

 

 

资金量指标

VARF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA

((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

VAR3:=(CLOSE-MA(CLOSE,0))/MA(CLOSE,0)*100;

VAR4:=(CLOSE-MA(CLOSE,0))/MA(CLOSE,0)*100;

VAR5:=(CLOSE-MA(CLOSE,0))/MA(CLOSE,0)*100;

VAR6:=(VAR3+VAR4+VAR5)/3;

ZH: EMA(EMA(VAR3,5),5)*3, COLORSTICK;

VAR10:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA

((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

VAR8:=IF(VAR6<=-20,10,0);

STICKLINE(VAR8=10,20,10,4,0),COLORRED;

VAR11:=VARF<REF(VAR10,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);

DRAWTEXT(VAR11 AND COUNT(VAR11,30)=1,5,'狮子提醒'),COLORFF00FF;

STICKLINE(VAR11 AND COUNT(VAR11,30)=1,1,10,8,0),COLORYELLOW;

DRAWTEXT(VAR11 AND COUNT(VAR11,30)=1,3,'大资金进入'),COLORFF00FF;

 

 

机构做空能量线

VAR1:=(HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;

机构做空能量线: SMA(VAR1,3,1),LINETHICK2,COLORGREEN;

VAR2:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

机构做多能量线: SMA(VAR2,5,1)-8,LINETHICK2,COLORRED;

弱势区:20,POINTDOT,COLORGREEN;

强弱分水岭:50,POINTDOT,COLORWHITE;

强势区:80,POINTDOT,COLORF00FF0;

 

专业快刀手

 

N1:=21;

VAR1:=4*SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1)-

3*SMA(SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1),3.2,1),COLORYELLOW,LINETHICK1;

VAR2:=8,COLORGREEN,LINETHICK0;

小试牛刀: IF(CROSS(VAR1,VAR2),50,0),STICK,COLORRED;

DRAWICON(小试牛刀>0,50,4);

发现庄迹: IF(VAR1<=8,15,0),STICK,COLORCYAN,LINETHICK2;

VARO5:=LLV(LOW,27);

VARO6:=HHV(HIGH,34);

VARO7:=EMA((CLOSE-VARO5)/(VARO6-VARO5)*4,4)*25;

建仓区: IF((VARO7<10),100,118) ,COLOR00CCFF,LINETHICK1;

CD1:=(HHV(H,9)-C)/(HHV(H,9)-LLV(L,9))-0.7;

CD2:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9));

CD3:=SMA(SMA(CD2,3,1),3,1);

CD4:=(CD3-SMA(CD1,9,1))-0.5;

CD5:=IF(CD4>0.00,CD4,0.00);

CD6:=REF(CD5,1);

VAR81:=MA(C,9),COLORRED;

空头1:=IF(CD6-CD5,CD6,CD5),LINETHICK3,COLORGREEN;

减仓空仓:CROSS(CD6,CD5),COLORGREEN;

DRAWICON(减仓空仓>0,113,5);

VAR1A:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;

VAR2A:=SMA(VAR1A,9,1)+100;

VAR3A:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

VAR4A:=SMA(VAR3A,3,1);

VAR5A:=SMA(VAR4A,3,1)+100;

VAR6A:=VAR5A-VAR2A;

端庄窝:=IF(VAR6A>N1,VAR6A-N1,0),COLORLIRED;

果断出击:IF(CROSS(端庄窝,0.01),100,0),STICK,COLORGREEN,LINETHICK2;

DRAWICON(果断出击>0,100,4),COLORGREEN;

XG:=CROSS(端庄窝,0.01);

LC:=REF(CLOSE,1);

RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;

E:=CROSS(83,RSI);

STICKLINE(REF(端庄窝,1)<端庄窝,端庄窝,REF(端庄窝,1),3,0),COLORRED;

STICKLINE(REF(端庄窝,1)>端庄窝,端庄窝,REF(端庄窝,1),3,0),COLOR00FF00;

红持绿空:0,COLORGREEN;

中分线: 20;

VAR1E:=((CLOSE - LLV(LOW,20)) / (HHV(HIGH,20) - LLV(LOW,20))) * 100;

VAR2E:=SMA(SMA(VAR1E,3,1),3,1);

VAR3E:=EMA(VAR2E,5);

GZ:=3*VAR2E-2*VAR3E;

趋势J:EMA(GZ,3),colorgreen,linethick3;

partline(趋势J>ref(趋势J,1),趋势J),colorred,linethick3;

VAR37:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;

VAR38:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;

VAR39:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;

副图K线

RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;

K:SMA(RSV,3,1);

D:SMA(K,3,1);

J:=3*K-2*D;

100,COLOR00FF00;

0,COLORFF00FF;

STICKLINE(J>REF(J,1),HHV(J,3),LLV(J,3),0,0),COLORRED;

STICKLINE(J>REF(J,1),J,REF(J,1),3,0),COLORRED;

STICKLINE(J>REF(J,1),J,REF(J,1),2,0),COLOR000099;;

STICKLINE(J>REF(J,1),J,REF(J,1),1,0),COLOR2F2FF0;

STICKLINE(J<REF(J,1),HHV(J,3),LLV(J,3),0,0),COLORFFAA00;

STICKLINE(J<REF(J,1),J,REF(J,1),3,0),COLORFF3300;

STICKLINE(J<REF(J,1),J,REF(J,1),1.5,0),COLORFF6600;

STICKLINE(J<REF(J,1),J,REF(J,1),0,0),COLORFFAA00;

 

一品操盘

STICKLINE(C>=O OR (C=O AND C>REF(C,1)),O,C,4,1),COLORRED;

STICKLINE((C>=O AND C<>H) OR (C=O AND C>REF(C,1)),C,H,0.1,0),COLORRED;

STICKLINE((C>=O AND L<>O) OR (C=O AND C>REF(C,1)),L,O,0.1,0),COLORRED;

STICKLINE(C<O OR (C=O AND C>REF(C,1)),O,C,4,0),COLORCYAN;

STICKLINE((C<O AND C<>H) OR (C=O AND C>REF(C,1)),C,H,0.1,1),COLORCYAN;

STICKLINE((C<O AND L<>O) OR (C=O AND C>REF(C,1)),L,O,0.1,1),COLORCYAN;

压力:HHV(MA((LOW+HIGH+CLOSE)/3,1),34),LINETHICK2,COLORGREEN;

支撑:LLV(MA((LOW+HIGH+CLOSE)/3,1),34),LINETHICK2,COLORRED;

RV:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;

RG:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;

VA1:=SMA(RV,3,1);

VA2:=SMA(VA1,3,1);

ZZ:=EMA(SMA(RG,3,1),2);

XX:=SMA(ZZ,3,1);

DRAWICON(CROSS(VA1,VA2) AND CROSS(ZZ,XX),L,1);

DRAWICON(CROSS(VA2,VA1) AND CROSS(XX,ZZ),H,2);

 

天机均线

均:=(3*C+H+L+O)/6;

短线:(8*均+7*REF(均,1)+6*REF(均,2)+5*REF(均,3)+4*REF(均,4)+3*REF(均,5)+2*REF(均,6)+REF(均,7))/36,COLORWHITE,PRECIS0;

中线:(LLV(短线,3)+LLV(短线,5)+LLV(短线,8))/3,COLORYELLOW,PRECIS0;

 

无双多空

VAR1A:=LLV(LOW,21);

VAR2A:=HHV(HIGH,21);

AK1:=EMA((((CLOSE - VAR1A) / (VAR2A - VAR1A)) * 100),5);

AK:=EMA((((CLOSE - VAR1A) / (VAR2A - VAR1A)) * 50),13);

AB:=CROSS(AK1,AK);

DRAWTEXT((AB=1),L,'建多'),COLORYELLOW;

VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);

VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);

STICKLINE(C>=O OR (C=O AND C>REF(C,1)),O,C,4,1),COLORRED;

STICKLINE((C>=O AND C<>H) OR (C=O AND C>REF(C,1)),C,H,0.1,0),COLORRED;

STICKLINE((C>=O AND L<>O) OR (C=O AND C>REF(C,1)),L,O,0.1,0),COLORRED;

STICKLINE(C<O OR (C=O AND C>REF(C,1)),O,C,4,0),COLORCYAN;

STICKLINE((C<O AND C<>H) OR (C=O AND C>REF(C,1)),C,H,0.1,1),COLORCYAN;

STICKLINE((C<O AND L<>O) OR (C=O AND C>REF(C,1)),L,O,0.1,1),COLORCYAN;

DRAWTEXT(FILTER((VAR4AA>90),45),L,'★大胆多 '),COLOR00FFFF;

VAR1:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100;

VAR2:=SMA(VAR1,3,1);

VAR3:=SMA(VAR2,3,1);

VAR5:=CROSS(SMA(VAR2,3,1),SMA(VAR3,3,1)) AND SMA(VAR2,3,1)<20;

DRAWTEXT(FILTER(VAR5,10)=1,LOW,'抄底'),COLORYELLOW;

VARA:=LLV(LOW,35);

VARB:=HHV(HIGH,30);

VARC:=EMA((CLOSE-VARA)/(VARB-VARA)*4,4)*25;

DRAWTEXT(IF(CROSS(87.5,VARC),87,0),H,'空'),COLOR00FF00;

 

金山银山

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIFF,9);

STICKLINE(DIFF>DEA,CLOSE,OPEN,3,0),COLORRED;

STICKLINE(DIFF>DEA,HIGH,LOW,3,0),COLORRED;

STICKLINE(DIFF<=DEA,CLOSE,OPEN,3,0),COLORGREEN;

STICKLINE(DIFF<=DEA,HIGH,LOW,3,0),COLORGREEN;

 

量能指标

VAR1:=(HHV(HIGH,13)-LLV(LOW,13));

VAR2:=(HHV(HIGH,13)-CLOSE);

VAR3:=(CLOSE-LLV(LOW,13));

VAR4:=(((VAR2/VAR1)*100)-70);

VAR5:=(((CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60)))*100);

VAR6:=((((2*CLOSE)+HIGH)+LOW)/4);

VAR7:=SMA(((VAR3/VAR1)*100),3,1);

VAR8:=LLV(LOW,34);

VAR9:=(SMA(VAR7,3,1)-SMA(VAR4,9,1));

VAR10:=IF((VAR9>100),(VAR9-100),0);

VAR11:=HHV(HIGH,34);

VAR12:=EMA((((VAR6-VAR8)/(VAR11-VAR8))*100),N);

VAR13:=EMA(((0.667*REF(VAR12,1))+(0.333*VAR12)),2);

STICKLINE(((VAR12-VAR13)>0),VAR12,VAR13,4,0),COLOR0000FF;

STICKLINE(((VAR12-VAR13)<0),VAR12,VAR13,4,0),COLORFF0000;

MA11:EMA(VAR13,5);

(N  1  100  15  )

 

即时趋势

副图

R1:3*SMA((CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100,3,1)-2*SMA(SMA((CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100,3,1),2,1);

ZP:IF(R1<7,20,0),COLORGREEN;

XG:IF(CROSS(R1,7),38,0),COLORRED;

A:95,COLORGREEN;

 

快慢多空

主图叠加

AA10:=MA(C,10);

BB10:=ATAN((AA10-REF(AA10,1)))*180/3.1416;

STICKLINE(BB10>1 AND AA10>REF(AA10,1), AA10,REF(AA10,1),8,0),COLORRED;

STICKLINE(BB10<1 AND AA10<REF(AA10,1), AA10,REF(AA10,1),8,1),COLORGREEN;

AA20:=MA(C,20);

BB20:=ATAN((AA20-REF(AA20,1)))*180/3.1416;

STICKLINE(BB20>1,AA20,REF(AA20,1),8,0),COLORYELLOW;

STICKLINE(BB20<1,AA20,REF(AA20,1),8,1),COLORBBCCCC;

 

彩色K线

HH:=HHV(HIGH,3);

LL:=LLV(LOW,3);

HH1:=BARSLAST((HH > REF(HH,1)));

LL1:=BARSLAST((LL < REF(LL,1)));

IF((HH1 < LL1),LL,HH),LINETHICK2,COLORBB0066;

IF((HH1 > LL1),HH,LL),LINETHICK2,COLOR1B8800;

STICKLINE((HH1 < LL1),CLOSE,OPEN,3,0),COLORRED;

STICKLINE((HH1 < LL1),HIGH,LOW,0,0),COLORRED;

STICKLINE((HH1 > LL1),CLOSE,OPEN,3,0),COLORFF0000;

STICKLINE((HH1 > LL1),HIGH,LOW,0,0),COLORFF0000;

DRAWTEXT(CROSS(HH1,LL1),HH,'开空'),COLORYELLOW;

DRAWTEXT(CROSS(LL1,HH1),LL,'开多'),COLORFF00FF;

标题:pobo博易大师期货指标(大集合)

分类:博易大师

链接:https://www.boyidashi.com/8669.html

版权:【免责声明】本文发布仅代表作者个人或公司观点,与本信息发布平台无关。文中陈述、观点判断保持中立,不对所包含内容的准确性、可靠性或完整性提供任何明示或暗示的保证。请读者仅作参考,并请自行承担全部责任。

相关文章